mshd.net
当前位置:首页 >> 易语言编辑框下按回车单击某个按钮 >>

易语言编辑框下按回车单击某个按钮

这也太简单了。。。还是好好学吧!以后这么简单的问题就不要提问了 这是学易语言的基矗、

.版本 2 .子程序 _登录按钮_被单击 信息框 (“恭喜你,登录成功1, 0, ) .子程序 _编辑框5_按下某键, 逻辑型 .参数 键代码, 整数型 .参数 功能键状态, 整数型 .如果真 (键代码 = #回车键) _登录按钮_被单击 () .如果真结束 ' 应该是你想要的效果...

版本 2 子程序 _登录按钮_被单击 信息框 (“恭喜你,登录成功1, 0, ) 子程序 _编辑框5_按下某键, 逻辑型 参数 键代码, 整数型 参数 功能键状态, 整数型 如果真 (键代码 = #回车键) _登录按钮_被单击 () 版本 2 子程序 _登录按钮_被单击 信息框 ...

.版本 2 .如果真 (键代码 = #回车键) .如果真 (编辑框1.内容 ≠ “”) _按钮1_被单击 () .如果真结束 .如果真结束 嗯,你这样对了,就直接调用那个按钮的程序就可以了

改为下面试试看 .版本 2 .子程序 _编辑框1_按下某键, 逻辑型 .参数 键代码, 整数型 .参数 功能键状态, 整数型 .如果真 (键代码 = #回车键) _按钮1_被单击 () 返回 (假) .如果真结束

.版本 2 .程序集 窗口程序集1 .子程序 __启动窗口_创建完毕 编辑框1.内容 = “123456789” .子程序 _按钮1_被单击 编辑框1.内容 = “”

给你个最简单的答案,把按钮类型设置默认就OK

你这是一个问题还是两个问题 编辑框1.内容 = 到文本 (到数值 (编辑框1.内容) + 1) 前面用这个很容易实现。 ctrl+v编辑框其实已经可以直接实现 你非要搞什么键代码,就用 模拟按键 (#Ctrl键, #V键, )

.版本 2.程序集 窗口程序集_启动窗口.程序集变量 a, 整数型.子程序 _按钮1_被单击.判断开始 (a = 1) 编辑框1.内容 = “aaa” a = a + 1.判断 (a = 2) 编辑框1.内容 = “ssss” a = a + 1.判断 (a = 3) 编辑框1.内容 = “dddd” a = a + 1....

.版本 2.程序集 窗口程序集1.子程序 __启动窗口_创建完毕.子程序 键判断, 逻辑型.参数 键, 整数型.判断开始 (键= -32767)返回 (真).默认返回 (假).判断结束.子程序 _时钟1_周期事件编辑框1.加入文本 (键盘记录 (取键盘指示灯状态 (1)))时钟周期...

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com