mshd.net
当前位置:首页 >> 易语言编辑框下按回车单击某个按钮 >>

易语言编辑框下按回车单击某个按钮

版本 2 子程序 _登录按钮_被单击 信息框 (“恭喜你,登录成功1, 0, ) 子程序 _编辑框5_按下某键, 逻辑型 参数 键代码, 整数型 参数 功能键状态, 整数型 如果真 (键代码 = #回车键) _登录按钮_被单击 () 版本 2 子程序 _登录按钮_被单击 信息框 ...

.版本 2 .如果真 (键代码 = #回车键) .如果真 (编辑框1.内容 ≠ “”) _按钮1_被单击 () .如果真结束 .如果真结束 嗯,你这样对了,就直接调用那个按钮的程序就可以了

改为下面试试看 .版本 2 .子程序 _编辑框1_按下某键, 逻辑型 .参数 键代码, 整数型 .参数 功能键状态, 整数型 .如果真 (键代码 = #回车键) _按钮1_被单击 () 返回 (假) .如果真结束

.版本 2 .支持库 spec .支持库 eAPI .子程序 _时钟1_周期事件 编辑框1.获取焦点 () 编辑框1.被选择字符数 = -1 延迟 (50) 模拟按键 (#Ctrl键, #C键, ) 延迟 (50) 编辑框3.获取焦点 () 模拟按键 (#回车键, , ) 延迟 (2) 模拟按键 (#Ctrl键, #V键...

.版本 2 .程序集 窗口程序集1 .子程序 _按钮1_被单击 编辑框1.内容 = 到文本 (到数值 (编辑框1.内容) + 1)

给你个最简单的答案,把按钮类型设置默认就OK

你这是一个问题还是两个问题 编辑框1.内容 = 到文本 (到数值 (编辑框1.内容) + 1) 前面用这个很容易实现。 ctrl+v编辑框其实已经可以直接实现 你非要搞什么键代码,就用 模拟按键 (#Ctrl键, #V键, )

.版本 2.程序集 窗口程序集_启动窗口.程序集变量 a, 整数型.子程序 _按钮1_被单击.判断开始 (a = 1) 编辑框1.内容 = “aaa” a = a + 1.判断 (a = 2) 编辑框1.内容 = “ssss” a = a + 1.判断 (a = 3) 编辑框1.内容 = “dddd” a = a + 1....

.版本 2 .子程序 _按钮_A_被单击 .如果真 (编辑框_A.内容 > 0) 编辑框1.内容 = 到整数 (编辑框1.内容) - 1 .如果真结束 .子程序 _按钮_斗地主_被单击 连续赋值 (“4”, 编辑框_A.内容, 编辑框_2.内容) 编辑框_王.内容 = “2” .子程序 _按钮_港...

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com